Mayor's posters

Link: Mayor's posters

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.
Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
Sample Output

4

Probelm solving

这道题的意思就是有一个广告板,现在你按照顺序往广告板上贴广告。每个广告都处于一个区间,问你最后能看到几个广告。题意看图很容易就明白了。
暴力写肯定是会TLE的。这是一道线段树的题。关键就是怎么用。我们可以发现,越靠后贴上的广告才可能是最后看得到的。所以我们可以倒着看,初始的时候每个点的值都设为,然后装上一个广告牌,将广告牌所在区间的值都改为,表示这个地方已经有广告牌了。所以我们可以这样用线段树,每次遇到一个位于的广告牌先查询这个区间的和,如果大于0,说明有的地方还没有广告,答案加一,然后将这个区间所有的值修改为0.这样就解决了本题。
但是还有一个问题就是,这样做的话我们需要按照广告板的长度去建树,而这个长度最长会是,会MLE。但是总共最多也就个广告,最多也就个点,所以我们需要对每个广告的左右区间离散化处理一下。这样就可以了。
还有个问题就是懒标记,因为模板中的pushdown都是if(lazy[rt]),所以我卡了好久。因为这里的lazy[rt]会是,所以我们把lazy数组直接初始化为即可。

Code

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
#define pb push_back
#define mp make_pair
const int maxn = 2e4 + 5;
const int mod = 1e9+7;
ll tree[maxn<<2],lazy[maxn<<2],a[maxn],cnt;
ll read()
{
    char c;
    ll ans=0,flag=1;
    while(c>'9'||c<'0'){
        if(c=='-')  flag=-1;
        c=getchar();
    }
    while(c>='0'&&c<='9'){
        ans=ans*10+c-'0';
        c=getchar();
    }
    return ans*flag;
}
struct node{
    ll l,r;
}p[maxn];
void build(int l,int r,int rt){
    if(l==r){
        tree[rt]=1;
        return ;
    }
    int mid=(l+r)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}
void pushdown(int rt,int ln,int rn){
    if(lazy[rt]==0){
        lazy[rt<<1]=lazy[rt];
        lazy[rt<<1|1]=lazy[rt];
        tree[rt<<1]=lazy[rt]*ln;
        tree[rt<<1|1]=lazy[rt]*rn;
        lazy[rt]=0;
    }
}
void update(int l,int r,int x,int y,int rt,int z){
    if(l>=x&&r<=y){
        tree[rt]=(r-l+1)*z;
        lazy[rt]=z;
        return ;
    }
    int mid=(l+r)>>1;
    pushdown(rt,mid-l+1,r-mid);
    if(x<=mid)  update(l,mid,x,y,rt<<1,z);
    if(y>mid)   update(mid+1,r,x,y,rt<<1|1,z);
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}
ll query(ll l,ll r,ll x,ll y,ll rt){
    // cout<<"query"<<" "<<x<<" "<<y<<endl;
    if(l>=x&&r<=y){
        return tree[rt];
    }
    ll mid=(l+r)>>1;
    pushdown(rt,mid-l+1,r-mid);
    ll ans=0;
    if(x<=mid)  ans+=query(l,mid,x,y,rt<<1);
    if(y>mid)   ans+=query(mid+1,r,x,y,rt<<1|1);
    return ans;
}
int main() {
    ll t;
    t=read();
    while(t--){
        ll n,ans=0;cnt=0;
        scanf("%lld",&n);
        for(ll i=1;i<=n;i++)   p[i].l=read(),p[i].r=read(),a[cnt++]=p[i].l,a[cnt++]=p[i].r;
        sort(a,a+cnt);
        cnt=unique(a,a+cnt)-a;
        for(int  i=1;i<=(cnt<<2);i++)   lazy[i]=-1;
        build(1,cnt,1);
        for(ll i=n;i>=1;i--){
            ll L=lower_bound(a,a+cnt,p[i].l) - a+1;
            ll R=lower_bound(a,a+cnt,p[i].r) - a+1;
            // cout<<L<<" "<<R<<endl;
            ll mid=query(1,cnt,L,R,1);
            // cout<<mid<<endl;
            if(mid>0)  ans++;
            update(1,cnt,L,R,1,0);
        }
        printf("%lld\n",ans);
    }
    return 0;
}