Buy Tickets

Link: Buy Tickets

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • ∈ [0, 32767] — The i-th person was assigned the value Vali.
  • There no blank lines between test cases. Proceed to the end of input.

Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Problem solving

题意很好理解,就是一堆人在排队,但是有人插队。问你最后的排队情况。
一开始我是想直接用vector的insert试一下的。无情TLE之后意识到,insert着写是的复杂度233
其实这道题是可以用线段树写的,我们让线段树每个节点的值代表这个区间所剩的空位的个数。然后按照倒序处理。因为倒着来的话有些位置是确定的。并且每次插入一个人的value,它前面的空位数是确定的。就是他插入的位置。因此线段树单点更新即可。复杂度

Code

#include<iostream>
using namespace std;
const int maxn = 2e5+10;
int tree[maxn<<2],n,ans[maxn];
struct node{
    int pos,val;
}p[maxn];
void build(int l,int r,int rt){
    if(l==r){    
        tree[rt]=1;//叶子节点都是只有一个空位
        return ;
    }
    int mid=(l+r)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}//建树
void add(int pos,int l,int r,int rt,int val){
    if(l==r){
        ans[l]=val;//储存答案方便输出
        tree[rt]=0;//如果用过了,就没有空位了
        return ;
    }
    int mid=(l+r)>>1;
    if(pos<=tree[rt<<1])    add(pos,l,mid,rt<<1,val);//如果需要的空位数小于等于左子节点的空位数,向左子树查询即可
    else  add(pos-tree[rt<<1],mid+1,r,rt<<1|1,val);//反之查询右子树,注意此时左子树节点的空位数相当于也放在这个点的前面了,所以现在需要的空位数是pos-tree[rt<<1]
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}
int main()
{
    while(~scanf("%d",&n)){
        build(1,n,1);
        for(int i=1;i<=n;i++){
            scanf("%d %d",&p[i].pos,&p[i].val);
        }
        for(int i=n;i>0;i--){
            add(p[i].pos+1,1,n,1,p[i].val);
        }
        for(int i=1;i<=n;i++){
            printf("%d ",ans[i]);
        }
        cout<<endl;
    }
    return 0;
}