Link: poj-2492

Description:
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Problem solving:
这道题的意思就是给你几组数,每组数有两个数代表这两个数,代表这两个编号的虫子是相爱的,即他们不是同性的。
问你输入的数据中会不会存在相同性别(同性恋)的情况存在。

这道题的做法还是很多的,二分图,带权并查集什么什么的。
但是上面那两个我都不熟悉。所以选择了裸并查集加一个小处理的办法。

这里我们用x+n代表跟x性别不同的虫子,每次join的时候对(x+n,y)和(x,y+n)进行join即可。然后如果出现性别相同的直接标记一下,就是并查集啦。因为这里性别是有两种,说明是要分成两队的,直接并查集显然是不可以的。

Code:

#include <iostream>
using namespace std;
#define zhengshu    int
const int maxn = 1e5;
int       p[maxn];
int find(int x)
{
    return p[x] != x ? p[x] = find(p[x]) : x;
}
void join(zhengshu x, zhengshu y)
{
    x = find(x), y = find(y);
    if (x != y)
        p[x] = y;
}
int main()
{
    zhengshu t, n, m, x, y;
    scanf("%d", &t);
    for (zhengshu j = 1; j <= t; j++)
    {
        zhengshu flag = 0;
        scanf("%d %d", &n, &m);
        for (zhengshu i = 1; i <= 2 * n; i++)
            p[i] = i;
        for (zhengshu i = 0; i < m; i++)
        {
            scanf("%d %d", &x, &y);
            if (find(x) == find(y))
                flag = 1;
            else
                join(x + n, y), join(x, y + n);
        }
        printf("Scenario #%d:\n", j);
        if (flag)
            puts("Suspicious bugs found!");
        else
            puts("No suspicious bugs found!");
        puts("");
    }
}