Link: HDU-1863

畅通工程

Description:
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。

Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。

Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。

Sample Input
3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100

Sample Output
3
?

The main thought of this problem is union-find.
Code:

#include <bits/stdc++.h>
using namespace std;
struct city
{
    int a;
    int b;
    int p;
}   c[105];
int p[105];
int find(int x)
{
    return p[x] != x ? p[x] = find(p[x]) : x;
}
void join(int x, int y)
{
    x = find(x);
    y = find(y);
    if (x != y)
        p[y] = x;
}
bool cmp(city x, city y)
{
    return x.p < y.p;
}
int main()
{
    // freopen("../in.txt", "r", stdin);
    // freopen("../out.txt", "w", stdout);
    int n, m;
    while (cin >> n >> m)
    {
        int sum = 0;
        if (n == 0)
            break;
        for (int i = 1; i <= m; i++)
            p[i] = i;
        for (int i = 0; i < n; i++)
            cin >> c[i].a >> c[i].b >> c[i].p;
        sort(c, c + n, cmp);
        for (int i = 0; i < n; i++)
        {
            if (find(c[i].a) != find(c[i].b))
            {
                join(c[i].a, c[i].b);
                sum += c[i].p;
            }
        }
        int flag = 0;
        for (int i = 1; i <= m; i++)
        {
            if (p[i] == i)
                flag++;
        }
        if (flag == 1)
            cout << sum << endl;
        else
            puts("?");
    }
    return 0;
}

Recommend: 算法导论--最小生成树(Kruskal和Prim算法)

Interjection: "spirited away" was released on June 21st. Do you want to go see it together?