poj 2431 Expedition

题目链接:poj 2431 Expedition
题目描述:
A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input

Line 1: A single integer, N

Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

Line N+2: Two space-separated integers, L and P
Output

Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input

4
4 4
5 2
11 5
15 10
25 10
Sample Output

2
Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
题意分析:
你需要驾驶一辆卡车行驶L单位距离。最开始时,卡车上有P单位的汽油。卡车每开1单位距离需要消耗1单位的汽油。如果在途中车上的汽油耗尽,卡车就无法继续前行,因而无法到达终点。在途中一共有N个加油站。给出每个加油站到终点的距离,以及这个加油站可以给卡车最多加多少汽油,并且卡车燃料箱的容量是没有限制的。如果卡车不能到达终点输出-1,否则输出最少停留,即需要加油的次数。

解题思路就是让卡车一直走下去,直至燃料箱中剩余为0的时候,看是不是经过了加油站,并且对那些加油站可以加的油的量进行判断,实现这一步,就可以用到优先队列。并且此时我们要给卡车加最多能加的油(体现贪心的地方)。我在这里用了结构体以及结构体的排序。
代码实现

#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int l,p,pos=0,ans=0,re;//re代表油箱中剩的油,pos代表现在所在的位置
priority_queue<int> q;
struct oil{
    int a,b;
}s[1000005];
bool cmp(oil x,oil y)
{
    return x.a<y.a;
}
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>s[i].a>>s[i].b;
    cin>>l>>p;
    for(int i=0;i<n;i++)
        s[i].a=l-s[i].a;
    sort(s,s+n,cmp);
    s[n].a=l;
    s[n].b=0;
    n++;
    re=p;
    for(int i=0;i<n;i++)
    {
        int d=s[i].a-pos;
        while(re-d<0)//这个while代表的是此时油箱中剩的油的量够不够走到下一个位置。
        {
            if(q.empty())//队列为空代表已经没有可以加油的地方了,也就是到不了终点了。
            {
                cout<<"-1"<<endl;
                return 0;
            }
            re+=q.top();
            q.pop();
            ans++;
        }
        re-=d;
        pos=s[i].a;
        q.push(s[i].b);
    }
    cout<<ans<<endl;
    return 0;
}